diff --git a/web/html/css/arch.css b/web/html/css/arch.css
index 42a66276..ffe713e9 100644
--- a/web/html/css/arch.css
+++ b/web/html/css/arch.css
@@ -431,9 +431,6 @@ textarea.vLargeTextField {
.frontpgboxbody > table {
width: 100%;
}
-.boxSoftTitle {
- text-align: right;
-}
.pgboxtitle {
border: 2px solid #ddd;
border-top: 1px solid #fff;
diff --git a/web/html/css/containers.css b/web/html/css/containers.css
index c0fb8773..c7a99731 100644
--- a/web/html/css/containers.css
+++ b/web/html/css/containers.css
@@ -95,7 +95,7 @@ td.div {
background-color: #eee;
width: 3px;
}
-td.boxSoftTitle {
+.boxSoftTitle {
border-bottom: 1px solid #fff;
border-top: 1px solid #fff;
background-color: #f1f2f4;
diff --git a/web/lib/pkgfuncs.inc b/web/lib/pkgfuncs.inc
index e328c301..b6f32e6a 100644
--- a/web/lib/pkgfuncs.inc
+++ b/web/lib/pkgfuncs.inc
@@ -287,187 +287,11 @@ function package_details($id=0, $SID="") {
if (empty($row)) {
print __("Package details could not be found.")."
\n";
- } else {
-
- # print out package details
- #
- echo "
"; - echo $row["Name"] . " " . $row["Version"]." | ||||||||
"; - echo "".$row["URL"]." | ||||||||
".$row["Description"]; - echo " | ||||||||
![]() | ||||||||
"; - if ($row["Location"] == "unsupported" and ( - $uid == $row["MaintainerUID"] or - ($atype == "Developer" or - $atype == "Trusted User"))) { - $edit_cat = "".$row["Category"].""; - $edit_cat .= " ("; - $edit_cat .= __("change category").")"; - } else { - $edit_cat = $row["Category"]; - } - echo $row["Location"]." :: ".$edit_cat." | ||||||||
".__("Maintainer").": "; - if ($row["MaintainerUID"]) { - $maintainer = username_from_id($row["MaintainerUID"]); - if ($SID) { - echo ""; - echo $maintainer . " | "; - } else { - echo $maintainer . ""; - } - } else { - $maintainer = "None"; - echo $maintainer . ""; - } - echo "||||||||
".__("Votes").": "; - echo $row["NumVotes"] . " | ||||||||
".__("License").": ".$license; - echo " | ||||||||
![]() | ||||||||
";
- echo __("Last Updated").": ".$updated_time." "; - echo __("First Submitted").": ".$submitted_time." | ||||||||
![]() | ||||||||
"; - if ($row["LocationID"] == 2) { - $urlpath = URL_DIR.$row["Name"]."/".$row["Name"]; - print "".__("Tarball")." :: ".__("Files")." :: PKGBUILD | "; - } elseif ($row["LocationID"] == 3) { - echo "CVS"; - } - echo "||||||||
"; - echo "".__("This package has been flagged out of date.")." | ||||||||
![]() | ||||||||
\n";
- echo "
| ";
-
- }
-
- $deps = package_required($row["ID"]);
- if (count($deps) > 0) {
-
- echo " ";
- echo "
| \n";
-
- }
-
- $sources = package_sources($row["ID"]); # $sources[0] = 'src';
- if (count($sources) > 0) {
-
- echo " \n";
- echo "
| \n";
-
- }
-
- echo "
+
+ ' . $row['URL'] ?>
+
+
+
+
+
+
+ +
+
+
+
+
+
+".__("Tarball")." :: ".__("Files")." :: PKGBUILD";
+ }
+ elseif ($row['LocationID'] == 3) {
+ echo "CVS";
+ }
+
+ if ($row["OutOfDate"] == 1) {
+ echo "
".__("This package has been flagged out of date.")."";
+ }
+?>
+
';
+ }
+
+ if (count($deps) > 0) {
+
+ echo "". __("Dependencies")."";
+
+ while (list($k, $darr) = each($deps)) {
+ $url = " ".$darr[1].$darr[3]."";
+ else echo " ".$darr[1].$darr[3]."";
+ }
+
+ if (count($requiredby) > 0) {
+ echo '
';
+ }
+ }
+
+ if (count($requiredby) > 0) {
+
+ echo "". __("Required by")."";
+
+ while (list($k, $darr) = each($requiredby)) {
+ $url = " " . $darr[1] . $darr[3] . "";
+ }
+ else {
+ print "".$darr[1].$darr[3]."";
+ }
+ }
+
+ }
+
+ if (count($deps) > 0 || count($requiredby) > 0) {
+ echo '